<!DOCTYPE html><html lang="en-US"><head ><meta charset="UTF-8" /><link data-optimized="2" rel="stylesheet" href="https://goodereader.com/blog/wp-content/litespeed/css/abe2e6d3edd8a17fefc9235a7448a94e.css?ver=0c95c" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>iReader X-Pen with Eraser – Hands on Review - Good e-Reader</title><meta name='robots' content='max-image-preview:large' /><meta property="og:description" content="iReader has had multiple generations of stylus that are compatible with virtually any digital note taking device with a WACOM screen and the company has just released their 3rd generation model. One of the big changes from the previous generation is that the stylus now has an eraser, but it is quite different from most erasers on the market, since it is recessed and does not pop down, like many cheap erasers. It also has lost the clip, which now makes it easier to hold. The iReader X-Pen with eraser comes in white and is quite easy to hold in"><meta property="og:title" content="iReader X-Pen with Eraser &#8211; Hands on Review"><meta property="article_publisher" content="https://facebook.com/goodereader/"><meta property="og:image" content="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen.png"><meta property="fb:app_id" content="529576650555031"><meta property="og:type" content="article"><meta property="og:url" content="https://goodereader.com/blog/reviews/ireader-x-pen-with-eraser-hands-on-review"><meta property="og:site_name" content="Good e-Reader"><meta property="article:published_time" content="2021-09-30T19:04:08-04:00"><meta property="article:modified_time" content="2021-09-30T19:04:08-04:00"><meta property="og:updated_time" content="2021-09-30T19:04:08-04:00"><meta name="twitter:title" content="iReader X-Pen with Eraser &#8211; Hands on Review"><meta name="twitter:description" content="iReader has had multiple generations of stylus that are compatible with virtually any digital note taking device with a WACOM screen and the company has just released their 3rd generation model. One of the big changes from the previous generation is that the stylus now has an eraser, but it is quite different from most erasers on the market, since it is recessed and does not pop down, like many cheap erasers. It also has lost the clip, which now makes it easier to hold. The iReader X-Pen with eraser comes in white and is quite easy to hold in"><meta name="twitter:image" content="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen.png"><meta name="twitter:site" content="@goodereader"><meta name="twitter:creator" content="@goodereader"><meta name="twitter:card" content="summary_large_image"><style>@font-face {
		font-family: "sw-icon-font";
		src:url("https://goodereader.com/blog/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0");
		src:url("https://goodereader.com/blog/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0#iefix") format("embedded-opentype"),
		url("https://goodereader.com/blog/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.3.0") format("woff"),
		url("https://goodereader.com/blog/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.3.0") format("truetype"),
		url("https://goodereader.com/blog/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.3.0#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}</style><meta name="description"  content="iReader has had multiple generations of stylus that are compatible with virtually any digital note taking device with a WACOM screen and the company has just" /><link rel="canonical" href="https://goodereader.com/blog/reviews/ireader-x-pen-with-eraser-hands-on-review" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//secure.rating-widget.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//www.googletagservices.com' /><link rel='dns-prefetch' href='//adservice.google.com' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel='dns-prefetch' href='//tpc.googlesyndication.com' /><link rel='dns-prefetch' href='//bp.blogspot.com' /><link rel='dns-prefetch' href='//1.bp.blogspot.com' /><link rel='dns-prefetch' href='//2.bp.blogspot.com' /><link rel='dns-prefetch' href='//3.bp.blogspot.com' /><link rel='dns-prefetch' href='//4.bp.blogspot.com' /><link rel='dns-prefetch' href='//ajax.microsoft.com' /><link rel='dns-prefetch' href='//ajax.aspnetcdn.com' /><link rel='dns-prefetch' href='//s3.amazonaws.com' /><link rel='dns-prefetch' href='//z-na.amazon-adsystem.com' /><link rel='dns-prefetch' href='//code.jquery.com' /><link rel='dns-prefetch' href='//stackpath.bootstrapcdn.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//player.vimeo.com' /><link rel='dns-prefetch' href='//github.githubassets.com' /><link rel='dns-prefetch' href='//0.gravatar.com' /><link rel='dns-prefetch' href='//2.gravatar.com' /><link rel='dns-prefetch' href='//1.gravatar.com' /><link rel='dns-prefetch' href='//ad.doubleclick.net' /><link rel='dns-prefetch' href='//googleads.g.doubleclick.net' /><link rel='dns-prefetch' href='//stats.g.doubleclick.net' /><link rel='dns-prefetch' href='//cm.g.doubleclick.net' /><link rel='dns-prefetch' href='//stats.buysellads.com' /><link rel='dns-prefetch' href='//s3.buysellads.com' /><link rel='dns-prefetch' href='//maps.googleapis.com' /><link rel='dns-prefetch' href='//maps.gstatic.com' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//apis.google.com' /><link rel='dns-prefetch' href='//google-analytics.com' /><link rel='dns-prefetch' href='//www.google-analytics.com' /><link rel='dns-prefetch' href='//ssl.google-analytics.com' /><link rel='dns-prefetch' href='//youtube.com' /><link rel='dns-prefetch' href='//api.pinterest.com' /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//pixel.wp.com' /><link rel='dns-prefetch' href='//connect.facebook.net' /><link rel='dns-prefetch' href='//platform.twitter.com' /><link rel='dns-prefetch' href='//syndication.twitter.com' /><link rel='dns-prefetch' href='//platform.instagram.com' /><link rel='dns-prefetch' href='//s7.addthis.com' /><link rel='dns-prefetch' href='//platform.linkedin.com' /><link rel='dns-prefetch' href='//w.sharethis.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//s.gravatar.com' /><link rel='dns-prefetch' href='//stats.wp.com' /><link rel='dns-prefetch' href='//secure.gravatar.com' /><link rel='dns-prefetch' href='//aax-us-east.amazon-adsystem.com' /><link rel='dns-prefetch' href='//a2.adform.net' /><link rel='dns-prefetch' href='//wms-na.amazon-adsystem.com' /><link rel='dns-prefetch' href='//static.adsafeprotected.com' /><link rel='dns-prefetch' href='//pixel.adsafeprotected.com' /><link rel='dns-prefetch' href='//d9.flashtalking.com' /><link rel='dns-prefetch' href='//cdn.flashtalking.com' /><link rel='dns-prefetch' href='//static.xx.fbcdn.net' /><link rel='dns-prefetch' href='//external-sea1-1.xx.fbcdn.net' /><link rel='dns-prefetch' href='//c.disquscdn.com' /><link rel='dns-prefetch' href='//www.gstatic.com' /><link rel="alternate" type="application/rss+xml" title="Good e-Reader &raquo; Feed" href="https://goodereader.com/blog/feed" /><link rel="alternate" type="application/rss+xml" title="Good e-Reader &raquo; Comments Feed" href="https://goodereader.com/blog/comments/feed" /><link rel="alternate" type="application/rss+xml" title="Good e-Reader &raquo; iReader X-Pen with Eraser &#8211; Hands on Review Comments Feed" href="https://goodereader.com/blog/reviews/ireader-x-pen-with-eraser-hands-on-review/feed" /><link rel='stylesheet' id='layerslider-css'  href='https://goodereader.com/blog/wp-content/plugins/LayerSlider/assets/static/layerslider/css/layerslider.css?ver=6.11.9' media='all' /><style id='magazine-pro-inline-css'>button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.archive-pagination li a:focus,
		.archive-pagination li a:hover,
		.archive-pagination li.active a,
		.button:focus,
		.button:hover,
		.entry-content .button:focus,
		.entry-content .button:hover,
		.sidebar .tagcloud a:focus,
		.sidebar .tagcloud a:hover,
		.sidebar .widget a.button:focus,
		.sidebar .widget a.button:hover,
		.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:focus,
		.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:hover,
		.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:focus,
		.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:hover,
		.widget-area .enews-widget input[type="submit"] {
			background-color: #469bd1;
			color: #222222;
		}

		

		a,
		.entry-title a:focus,
		.entry-title a:hover,
		.nav-secondary .genesis-nav-menu a:focus,
		.nav-secondary .genesis-nav-menu a:hover,
		.nav-secondary .genesis-nav-menu .current-menu-item > a,
		.nav-secondary .genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.nav-secondary .genesis-nav-menu .sub-menu .current-menu-item > a:hover {
			color: #469bd1;
		}
		
		.custom-logo-link,
		.wp-custom-logo .title-area {
			max-width: 380px;
		}

		.wp-custom-logo .header-widget-area {
			max-width: calc(99% - 380px);
		}</style><link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://goodereader.com/blog/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=5.7.1' media='only screen and (max-width: 1023px)' /><style id='magazine-woocommerce-styles-inline-css'>.content .wc-block-grid__product-add-to-cart .wp-block-button__link.add_to_cart_button:focus,
		.content .wc-block-grid__product-add-to-cart .wp-block-button__link.add_to_cart_button:hover,
		.woocommerce a.button:focus,
		.woocommerce a.button:hover,
		.woocommerce a.button.alt:focus,
		.woocommerce a.button.alt:hover,
		.woocommerce button.button:focus,
		.woocommerce button.button:hover,
		.woocommerce button.button.alt:focus,
		.woocommerce button.button.alt:hover,
		.woocommerce input.button:focus,
		.woocommerce input.button:hover,
		.woocommerce input.button.alt:focus,
		.woocommerce input.button.alt:hover,
		.woocommerce input[type="submit"]:focus,
		.woocommerce input[type="submit"]:hover,
		.woocommerce span.onsale,
		.woocommerce #respond input#submit:focus,
		.woocommerce #respond input#submit:hover,
		.woocommerce #respond input#submit.alt:focus,
		.woocommerce #respond input#submit.alt:hover,
		.woocommerce-cart #payment input[type="submit"]:focus,
		.woocommerce-cart #payment input[type="submit"]:hover,
		.woocommerce-cart #payment .button:focus,
		.woocommerce-cart #payment .button:hover,
		.woocommerce-checkout #payment input[type="submit"]:focus,
		.woocommerce-checkout #payment input[type="submit"]:hover,
		.woocommerce-checkout #payment .button:focus,
		.woocommerce-checkout #payment .button:hover,
		#add_payment_method #payment input[type="submit"]:focus,
		#add_payment_method #payment input[type="submit"]:hover,
		#add_payment_method #payment .button:focus,
		#add_payment_method #payment .button:hover {
			background-color: #469bd1;
			color: #222222;
		}

		.woocommerce.widget_price_filter .ui-slider .ui-slider-handle,
		.woocommerce.widget_price_filter .ui-slider .ui-slider-range {
			background-color: #469bd1;
		}

		ul.woocommerce-error,
		.woocommerce-error,
		.woocommerce-info,
		.woocommerce-message {
			border-top-color: #469bd1;
		}

		

		.woocommerce div.product p.price,
		.woocommerce div.product span.price,
		.woocommerce div.product .woocommerce-tabs ul.tabs li a:focus,
		.woocommerce div.product .woocommerce-tabs ul.tabs li a:hover,
		.woocommerce ul.products li.product h3:hover,
		.woocommerce ul.products li.product .price,
		.woocommerce .widget_layered_nav ul li.chosen a::before,
		.woocommerce .widget_layered_nav_filters ul li a::before,
		.woocommerce .woocommerce-breadcrumb a:focus,
		.woocommerce .woocommerce-breadcrumb a:hover,
		.woocommerce-error::before,
		.woocommerce-info::before,
		.woocommerce-message::before {
			color: #469bd1;
		}</style><style id='woocommerce-inline-inline-css'>.woocommerce form .form-row .required { visibility: visible; }</style><style id='dashicons-inline-css'>[data-font="Dashicons"]:before {font-family: 'Dashicons' !important;content: attr(data-icon) !important;speak: none !important;font-weight: normal !important;font-variant: normal !important;text-transform: none !important;line-height: 1 !important;font-style: normal !important;-webkit-font-smoothing: antialiased !important;-moz-osx-font-smoothing: grayscale !important;}</style><style id='wppr-common-inline-css'>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</style><style id='yith-wacp-frontend-inline-css'>#yith-wacp-popup .yith-wacp-content a.button {
                        background: #ebe9eb;
                        color: #515151;
                }
                #yith-wacp-popup .yith-wacp-content a.button:hover {
                        background: #dad8da;
                        color: #515151;
                }
#yith-wacp-popup .yith-wacp-wrapper{max-width:700px;max-height:700px;}#yith-wacp-mini-cart.empty{ visibility:hidden!important; }#yith-wacp-popup .yith-wacp-main{background-color: #ffffff;}
			#yith-wacp-popup .yith-wacp-overlay{background-color: #000000;}
			#yith-wacp-popup.open .yith-wacp-overlay{opacity: 0.4;}
			#yith-wacp-popup .yith-wacp-close{color: #ffffff;}
			#yith-wacp-popup .yith-wacp-close:hover{color: #c0c0c0;}
			#yith-wacp-popup .yith-wacp-message{color: #000000;background-color: #e6ffc5;}
			.yith-wacp-content .cart-info > div{color: #565656;}
			.yith-wacp-content .cart-info > div span{color: #000000;}
			.yith-wacp-content table.cart-list td.item-info .item-name:hover,.yith-wacp-content h3.product-title:hover{color: #565656;}
			.yith-wacp-content table.cart-list td.item-info .item-name,.yith-wacp-content table.cart-list td.item-info dl,.yith-wacp-content h3.product-title{color: #000000;}
			.yith-wacp-content table.cart-list td.item-info .item-price,.yith-wacp-content .product-price,.yith-wacp-content ul.products li.product .price,.yith-wacp-content ul.products li.product .price ins {color: #565656;}</style><style id='yith_wcbsl_frontend_style-inline-css'>.yith-wcbsl-badge-content{background:#a00000 !important; color:#ffffff !important;}
.yith-wcbsl-bestseller-positioning-in-product-wrapper a{background:#a00000 !important; color:#ffffff !important;}
.yith-wcbsl-bestseller-positioning-in-product-wrapper a:hover{background:#b33333 !important; color:#ffffff !important;}
.yith-wcbsl-bestseller-positioning-in-product-wrapper a:focus{background:#800000 !important; color:#ffffff !important;}</style><style id='magazine-pro-gutenberg-inline-css'>.ab-block-post-grid .ab-block-post-grid-more-link:hover,
.ab-block-post-grid header .ab-block-post-grid-title a:hover {
	color: #469bd1;
}

.button-more-link.ab-block-post-grid .ab-block-post-grid-more-link:hover,
.ab-block-post-grid .is-grid .ab-block-post-grid-image a .ab-block-post-grid-date,
.site-container .wp-block-button .wp-block-button__link {
	background-color: #469bd1;
	color: #222222;
}

.button-more-link.ab-block-post-grid .ab-block-post-grid-more-link:hover,
.wp-block-button .wp-block-button__link:not(.has-background),
.wp-block-button .wp-block-button__link:not(.has-background):focus,
.wp-block-button .wp-block-button__link:not(.has-background):hover {
	color: #222222;
}

.site-container .wp-block-button.is-style-outline .wp-block-button__link {
	color: #469bd1;
}

.site-container .wp-block-button.is-style-outline .wp-block-button__link:focus,
.site-container .wp-block-button.is-style-outline .wp-block-button__link:hover {
	color: #69bef4;
}

.site-container .wp-block-pullquote.is-style-solid-color {
	background-color: #469bd1;
}		.site-container .has-small-font-size {
			font-size: 12px;
		}		.site-container .has-normal-font-size {
			font-size: 16px;
		}		.site-container .has-large-font-size {
			font-size: 20px;
		}		.site-container .has-larger-font-size {
			font-size: 24px;
		}		.site-container .has-theme-primary-color,
		.site-container .wp-block-button .wp-block-button__link.has-theme-primary-color,
		.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-primary-color {
			color: #469bd1;
		}
		.site-container .has-theme-primary-background-color,
		.site-container .wp-block-button .wp-block-button__link.has-theme-primary-background-color,
		.site-container .wp-block-pullquote.is-style-solid-color.has-theme-primary-background-color {
			background-color: #469bd1;
		}		.site-container .has-theme-secondary-color,
		.site-container .wp-block-button .wp-block-button__link.has-theme-secondary-color,
		.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-secondary-color {
			color: #469bd1;
		}
		.site-container .has-theme-secondary-background-color,
		.site-container .wp-block-button .wp-block-button__link.has-theme-secondary-background-color,
		.site-container .wp-block-pullquote.is-style-solid-color.has-theme-secondary-background-color {
			background-color: #469bd1;
		}</style><link rel='stylesheet' id='rw_toprated-css'  href='https://secure.rating-widget.com/css/wordpress/toprated.css?ck=Y2021M09D30&#038;ver=3.1.2' media='all' /><link rel='stylesheet' id='rw_recommendations-css'  href='https://secure.rating-widget.com/css/widget/recommendations.css?ck=Y2021M09D30&#038;ver=3.1.2' media='all' /><style id='yith_ywsbs_frontend-inline-css'>.ywsbs-signup-fee{color:#467484;}.ywsbs-trial-period{color:#467484;}span.status.active{ color:#b2ac00;} span.status.paused{ color:#34495e;} span.status.pending{ color:#d38a0b;} span.status.overdue{ color:#d35400;} span.status.trial{ color:#8e44ad;} span.status.cancelled{ color:#c0392b;} span.status.expired{ color:#bdc3c7;} span.status.suspended{ color:#e74c3c;}</style><link rel='stylesheet' id='sccss_style-css'  href='https://goodereader.com/blog/?sccss=1&#038;ver=5.8.1' media='all' /> <script type="text/template" id="tmpl-variation-template"><div class="woocommerce-variation-description">{{{ data.variation.variation_description }}}</div>
	<div class="woocommerce-variation-price">{{{ data.variation.price_html }}}</div>
	<div class="woocommerce-variation-availability">{{{ data.variation.availability_html }}}</div></script> <script type="text/template" id="tmpl-unavailable-variation-template"><p>Sorry, this product is unavailable. Please choose a different combination.</p></script> <script src='https://goodereader.com/blog/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script src='https://goodereader.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <meta name="generator" content="Powered by LayerSlider 6.11.9 - Multi-Purpose, Responsive, Parallax, Mobile-Friendly Slider Plugin for WordPress." /><link rel="https://api.w.org/" href="https://goodereader.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://goodereader.com/blog/wp-json/wp/v2/posts/244322" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://goodereader.com/blog/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://goodereader.com/blog/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8.1" /><meta name="generator" content="WooCommerce 5.7.1" /><link rel='shortlink' href='https://goodereader.com/blog/?p=244322' /><link rel="alternate" type="application/json+oembed" href="https://goodereader.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review" /><link rel="alternate" type="text/xml+oembed" href="https://goodereader.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review&#038;format=xml" /><style type="text/css" media="screen">.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-5 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}</style> <script type="application/ld+json">{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://goodereader.com/blog/reviews/ireader-x-pen-with-eraser-hands-on-review"
    },
    "headline": "iReader X-Pen with Eraser - Hands on Review",
    "datePublished": "2021-09-30T19:04:08-0400",
    "dateModified": "2021-09-30T19:04:08-0400",
    "author": {
        "@type": "Person",
        "name": "Michael Kozlowski"
    },
    "description": "iReader has had multiple generations of stylus that are compatible with virtually any digital note taking devi",
    "image": {
        "@type": "ImageObject",
        "url": "https://goodereader.com/blog/uploads/images/2021/09/ireader-pen.png",
        "width": 2646,
        "height": 1329
    },
    "publisher": {
        "@type": "Organization",
        "name": "Good e-Reader",
        "logo": {
            "@type": "ImageObject",
            "url": "https://goodereader.com/blog/images/schema-logo-14.png",
            "width": 600,
            "height": 60
        }
    },
    "speakable": {
        "@type": "SpeakableSpecification",
        "xpath": [
            "/html/head/title",
            " /html/head/meta[@name=’description’]/@content"
        ]
    }
}</script> <link rel="apple-touch-icon" sizes="180x180" href="/blog/uploads/images/fbrfg/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/blog/uploads/images/fbrfg/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/blog/uploads/images/fbrfg/favicon-16x16.png"><link rel="manifest" href="/blog/uploads/images/fbrfg/site.webmanifest"><link rel="mask-icon" href="/blog/uploads/images/fbrfg/safari-pinned-tab.svg" color="#5bbad5"><link rel="shortcut icon" href="/blog/uploads/images/fbrfg/favicon.ico"><meta name="msapplication-TileColor" content="#da532c"><meta name="msapplication-config" content="/blog/uploads/images/fbrfg/browserconfig.xml"><meta name="theme-color" content="#ffffff"><style type="text/css">.saboxplugin-wrap{ border-top-style:solid !important; border-top-color:#eee !important; border-bottom-style:solid !important; border-bottom-color:#eee !important; border-left-style:solid !important; border-left-color:#eee !important; border-right-style:solid !important; border-right-color:#eee !important;}.saboxplugin-authorname .sabox-job-title{font-size:12px;opacity:.7;display: inline-block;margin-left: 10px;}</style><link rel="pingback" href="https://goodereader.com/blog/xmlrpc.php" /> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script> <script data-ad-client="ca-pub-5776314496161013" type="litespeed/javascript" data-i="1" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta name="google-site-verification" content="s_zn1VMhCDdqo406DW-TXw8qs_1Ls55wuzl8b1Nhupo" />	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/><link rel="amphtml" href="https://goodereader.com/blog/reviews/ireader-x-pen-with-eraser-hands-on-review/amp"><style type="text/css">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</style><link rel="icon" href="https://goodereader.com/blog/uploads/images/favicon.png" sizes="32x32" /><link rel="icon" href="https://goodereader.com/blog/uploads/images/favicon.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://goodereader.com/blog/uploads/images/favicon.png" /><meta name="msapplication-TileImage" content="https://goodereader.com/blog/uploads/images/favicon.png" /><style id="wp-custom-css">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</style><noscript><style>.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta name="google-site-verification" content="xamoeQNoIkJn_C7RBmsT0zyFhHLUtAD6BfRZ00GlAHI" /></head><body class="post-template-default single single-post postid-244322 single-format-standard wp-custom-logo wp-embed-responsive theme-genesis woocommerce-no-js yith-ctpw header-image content-sidebar genesis-breadcrumbs-hidden genesis-singular-image-hidden genesis-footer-widgets-hidden wpb-js-composer js-comp-ver-6.7.0 vc_responsive tgwc-woocommerce-customize-my-account" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope="" itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="header-tleft"></div><div class="header-tcenter">
<a href="https://goodereader.com/blog/" class="custom-logo-link" rel="home"><img src="https://goodereader.com/blog/uploads/images/2021/09/Good-E-Reader-Logo-Black-1.svg" class="custom-logo" alt="Good e-Reader" /></a><p class="site-title" itemprop="headline">Good e-Reader</p></div><div class="header-tright"><form role="search" method="get" class="search-form" action="https://goodereader.com/blog/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field"
placeholder="Search …"
value="" name="s"
title="Search for:" />
</label>
<input type="submit" class="search-submit"
value="" /></form></div></div></header><nav class="nav-secondary" aria-label="Secondary" id="genesis-nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-template-top" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-87860" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-87860"><a title="Contact" href="https://goodereader.com/blog/contact" itemprop="url"><span itemprop="name">Contact</span></a><ul class="sub-menu"><li id="menu-item-87866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87866"><a href="https://goodereader.com/blog/advertise" itemprop="url"><span itemprop="name">Advertise</span></a></li><li id="menu-item-244196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-244196"><a href="https://goodereader.com/blog/newsletter" itemprop="url"><span itemprop="name">Newsletter</span></a></li></ul></li><li id="menu-item-87841" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-87841"><a title="News" itemprop="url"><span itemprop="name">News</span></a><ul class="sub-menu"><li id="menu-item-181773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-181773"><a href="https://goodereader.com/blog/category/kindle" itemprop="url"><span itemprop="name">Amazon Kindle</span></a></li><li id="menu-item-96356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96356"><a href="https://goodereader.com/blog/category/audiobooks" itemprop="url"><span itemprop="name">Audiobooks</span></a></li><li id="menu-item-106630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-106630"><a href="https://goodereader.com/blog/category/barnes-and-noble-nook-ereader-news" itemprop="url"><span itemprop="name">Barnes and Noble</span></a></li><li id="menu-item-87851" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87851"><a href="https://goodereader.com/blog/category/e-book-news" itemprop="url"><span itemprop="name">e-Books</span></a></li><li id="menu-item-87852" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87852"><a href="https://goodereader.com/blog/category/e-paper" itemprop="url"><span itemprop="name">e-Paper</span></a></li><li id="menu-item-87847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87847"><a href="https://goodereader.com/blog/category/electronic-readers" itemprop="url"><span itemprop="name">e-Readers</span></a></li><li id="menu-item-88045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-88045"><a href="https://goodereader.com/blog/category/kobo-ereader-news" itemprop="url"><span itemprop="name">Kobo</span></a></li><li id="menu-item-186748" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-186748"><a href="https://goodereader.com/blog/category/onyx-boox" itemprop="url"><span itemprop="name">Onyx Boox</span></a></li><li id="menu-item-225879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225879"><a href="https://goodereader.com/blog/category/pocketbook-news" itemprop="url"><span itemprop="name">Pocketbook</span></a></li></ul></li><li id="menu-item-187846" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-187846"><a title="Reviews" href="https://goodereader.com/blog/category/reviews" itemprop="url"><span itemprop="name">Reviews</span></a></li><li id="menu-item-243147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-243147"><a href="#" itemprop="url"><span itemprop="name">Services</span></a><ul class="sub-menu"><li id="menu-item-106203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-106203"><a title="App Store" href="https://apps.goodereader.com" itemprop="url"><span itemprop="name">App Store</span></a></li><li id="menu-item-242925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-242925"><a href="https://auction.goodereader.com/" itemprop="url"><span itemprop="name">Auctions</span></a></li><li id="menu-item-194787" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-194787"><a href="https://goodereader.com/blog/manuals" itemprop="url"><span itemprop="name">User Guides</span></a></li><li id="menu-item-239856" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-239856"><a title="Vendor Marketplace" href="https://goodereader.com/blog/good-e-reader-vendor-market" itemprop="url"><span itemprop="name">Vendor Marketplace</span></a><ul class="sub-menu"><li id="menu-item-239855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-239855"><a href="https://goodereader.com/blog/vendor-registration" itemprop="url"><span itemprop="name">Registration</span></a></li><li id="menu-item-239857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-239857"><a href="https://goodereader.com/blog/marketplace-faq" itemprop="url"><span itemprop="name">Vendor FAQ</span></a></li><li id="menu-item-240339" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240339"><a target="_blank" rel="noopener" href="https://goodereader.com/blog/wp-admin/#new_tab" itemprop="url"><span itemprop="name">Vendor Login</span></a></li></ul></li></ul></li><li id="menu-item-105113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105113"><a title="Good e-Reader Store" href="https://goodereader.com/blog/shop" itemprop="url"><span itemprop="name">Good e-Reader Store</span></a><ul class="sub-menu"><li id="menu-item-189866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-189866"><a href="https://goodereader.com/blog/bestsellers" itemprop="url"><span itemprop="name">Best Sellers</span></a></li><li id="menu-item-243847" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243847"><a href="https://goodereader.com/blog/product-category" itemprop="url"><span itemprop="name">Categories</span></a></li><li id="menu-item-108008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-108008"><a href="https://goodereader.com/blog/My-Account" itemprop="url"><span itemprop="name">My Account</span></a></li><li id="menu-item-243735" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243735"><a href="https://goodereaderstore.com" itemprop="url"><span itemprop="name">Shopify Store</span></a></li></ul></li></ul></div></nav><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-nav-secondary" class="screen-reader-shortcut"> Skip to secondary menu</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-244322 post type-post status-publish format-standard has-post-thumbnail category-reviews entry" aria-label="iReader X-Pen with Eraser &#8211; Hands on Review" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">iReader X-Pen with Eraser &#8211; Hands on Review</h1><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2021-09-30T19:04:08-04:00">September 30, 2021</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://goodereader.com/blog/author/michael-kozlowski" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Michael Kozlowski</span></a></span> <span class="entry-comments-link"><a href="https://goodereader.com/blog/reviews/ireader-x-pen-with-eraser-hands-on-review#respond"><span class="dsq-postid" data-dsqidentifier="244322 https://goodereader.com/blog/?p=244322">Leave a Comment</span></a></span></p></header><div class="entry-content" itemprop="text"><p><img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjI2NDYiIGhlaWdodD0iMTMyOSIgdmlld0JveD0iMCAwIDI2NDYgMTMyOSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgc3R5bGU9ImZpbGw6I2NmZDRkYjtmaWxsLW9wYWNpdHk6IDAuMTsiLz48L3N2Zw==" loading="lazy" data-src="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen.png" alt="" width="2646" height="1329" class="alignnone size-full wp-image-244324" data-srcset="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen.png 2646w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-300x151.png 300w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-1024x514.png 1024w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-150x75.png 150w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-768x386.png 768w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-1536x771.png 1536w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-2048x1029.png 2048w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-50x25.png 50w, https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-750x377.png 750w" data-sizes="(max-width: 2646px) 100vw, 2646px"></p><p>iReader has had multiple generations of stylus that are compatible with virtually any digital note taking device with a WACOM screen and the company has just released their 3rd generation model. One of the big changes from the previous generation is that the stylus now has an eraser, but it is quite different from most erasers on the market, since it is recessed and does not pop down, like many cheap erasers. It also has lost the clip, which now makes it easier to hold.</p><p>The iReader X-Pen with eraser comes in white and is quite easy to hold in the hand. The stylus has a number of new improvements that make it one of the best 3rd party writing tools on the market. It has a new metal core, which is used not only for added heft, but also to magnetically attach to devices that have this type of support, such as the Remarkable 2. The nibs have also changed, instead of plastic ones, they are now made of graphite blended tip. This makes it easier to draw on glass based screens, since you get resistance when writing. Plastic nibs are not really ideal for writing on glass, since they sometimes slip and slide all over the place. Graphite tends to wear down more than a plastic nib, but replacements are really affordable.</p><p>The eraser that the X-Pen is using is very interesting. It feels like it is capacitive, but its not. The eraser is actually a really new concept and has never been seen before in a stylus. Most stylus have a protruding plastic top, and when you want to delete something on the screen, and you press down, the eraser actually presses down, and providing an audible clicking sound. This can be disjointing, because in the real world, erasers don&rsquo;t don&rsquo;t do this. This new eraser can be tilted, which makes deleting content fun!</p><p>The overall design is a bit different than normal plastic pens. This has a hexagonal shape, which makes it easy to hold and has a firm grip. One of the things that is very compelling about this new product is the sheer number of devices it supports. You can use it on the Remarkable 1 and Remarkable 2, Supernote, all of the Onyx e-notes made in the past three years and the previous generation of Boyue Likebook&rsquo;s. It retails for $89, making it more affordable than most premium stylus on the market. You can order it from the <a href="https://goodereader.com/blog/product/ireader-x-pen-gen-3">Good e-Reader Store</a>.</p><p><iframe data-lazyloaded="1" src="about:blank" loading="lazy" width="560" height="315" data-litespeed-src="https://www.youtube.com/embed/qEba6V0WJWk" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe><br><div class="a-single a-6"><center><script type="litespeed/javascript" data-i="2" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5776314496161013"
data-ad-slot="2642032174"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript" data-i="3">(adsbygoogle=window.adsbygoogle||[]).push({})</script></center></div><div id="wppr-review-244322" class="wppr-template wppr-template-default  wppr-review-container  "><section id="review-statistics" class="article-section"><div class="review-wrap-up  cwpr_clearfix"><div class="cwpr-review-top cwpr_clearfix"><h2 class="cwp-item">iReader X-Pen with Eraser</h2>
<span class="cwp-item-price cwp-item">$89.99</span></div><div class="review-wu-content cwpr_clearfix"><div class="review-wu-left"><div class="review-wu-left-top"><div class="rev-wu-image">
<a title="iReader X-Pen with Eraser" class="wppr-default-img" href="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen.png" data-lightbox="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-150x75.png" rel="nofollow" target="_blank">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjE1MCIgaGVpZ2h0PSI3NSIgdmlld0JveD0iMCAwIDE1MCA3NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgc3R5bGU9ImZpbGw6I2NmZDRkYjtmaWxsLW9wYWNpdHk6IDAuMTsiLz48L3N2Zw==" width="150" height="75" data-src="https://goodereader.com/blog/uploads/images/2021/09/ireader-pen-150x75.png" alt="iReader X-Pen with Eraser" class="photo photo-wrapup wppr-product-image">
</a></div><div class="review-wu-grade"><div class="review-wu-grade-content "><div class="wppr-c100 wppr-p95 wppr-very-good">
<span>4.75</span><div class="wppr-slice"><div class="wppr-bar " style="
-webkit-transform: rotate(342deg);
-ms-transform: rotate(342deg);
transform: rotate(342deg);
"></div><div class="wppr-fill " style=""></div></div><div class="wppr-slice-center"></div></div></div></div></div><div class="review-wu-bars"><div class="rev-option" data-value="100"><div class="cwpr_clearfix">
<span><h3>Design</h3>
</span>
<span>5.0/5</span></div><ul class="cwpr_clearfix wppr-very-good wppr-custom-icon"><li class="colored"><li class="colored"><li class="colored"><li class="colored"><li class="colored"></ul></div><div class="rev-option" data-value="95"><div class="cwpr_clearfix">
<span><h3>Functionality</h3>
</span>
<span>4.8/5</span></div><ul class="cwpr_clearfix wppr-very-good wppr-custom-icon"><li class="colored"><li class="colored"><li class="colored"><li class="colored"><li class="colored"></ul></div><div class="rev-option" data-value="95"><div class="cwpr_clearfix">
<span><h3>Drawing</h3>
</span>
<span>4.8/5</span></div><ul class="cwpr_clearfix wppr-very-good wppr-custom-icon"><li class="colored"><li class="colored"><li class="colored"><li class="colored"><li class="colored"></ul></div><div class="rev-option" data-value="95"><div class="cwpr_clearfix">
<span><h3>PDF Files</h3>
</span>
<span>4.8/5</span></div><ul class="cwpr_clearfix wppr-very-good wppr-custom-icon"><li class="colored"><li class="colored"><li class="colored"><li class="colored"><li class="colored"></ul></div><div class="rev-option" data-value="90"><div class="cwpr_clearfix">
<span><h3>Accessibility</h3>
</span>
<span>4.5/5</span></div><ul class="cwpr_clearfix wppr-very-good wppr-custom-icon"><li class="colored"><li class="colored"><li class="colored"><li class="colored"><li class="colored"></ul></div></div></div><div class="review-wu-right"><div class=" pros"><h2 class="">
Pros</h2><ul><li>Eraser is the best in the business</li><li>Graphite Tip</li><li>Magnetic Snap</li><li>Works on many EMR screens</li><li>Priced well</li></ul></div><div class=" cons"><h2 class="">
Cons</h2><ul><li>iReader is not well known in the United States</li><li>Graphite nibs wear down easier</li></ul></div></div></div></div></section><div class="affiliate-button">
<a href="https://goodereader.com/blog/product/ireader-x-pen-gen-3" rel="nofollow" target="_blank">
<span>Buy Now</span>
</a></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"Product","name":"iReader X-Pen with Eraser","image":"https:\/\/goodereader.com\/blog\/uploads\/images\/2021\/09\/ireader-pen-150x75.png","description":"iReader has had multiple generations of stylus that are compatible with virtually any digital note taking device with a WACOM screen and the company has just released their 3rd generation model. One of the big changes from the previous generation is that the stylus now has an eraser, but it is quite different from most...","offers":{"@type":"Offer","price":"89.99","priceCurrency":"USD","seller":{"@type":"Person","name":"Michael Kozlowski"}},"review":[{"@type":"Review","reviewRating":{"@type":"Rating","bestRating":"5","worstRating":"0","ratingValue":"4.75"},"name":"iReader X-Pen with Eraser","reviewBody":"iReader has had multiple generations of stylus that are compatible with virtually any digital note taking device with a WACOM screen and the company has just released their 3rd generation model. One of the big changes from the previous generation is that the stylus now has an eraser, but it is quite different from most erasers on the market, since it is recessed and does not pop down, like many cheap erasers. It also has lost the clip, which now makes it easier to hold. \r\n\r\nThe iReader X-Pen with eraser comes in white and is quite easy to hold in the hand. The stylus has a number of new improvements that make it one of the best 3rd party writing tools on the market. It has a new metal core, which is used not only for added heft, but also to magnetically attach to devices that have this type of support, such as the Remarkable 2. The nibs have also changed, instead of plastic ones, they are now made of graphite blended tip. This makes it easier to draw on glass based screens, since you get resistance when writing. Plastic nibs are not really ideal for writing on glass, since they sometimes slip and slide all over the place. Graphite tends to wear down more than a plastic nib, but replacements are really affordable.\r\n\r\nThe eraser that the X-Pen is using is very interesting. It feels like it is capacitive, but its not. The eraser is actually a really new concept and has never been seen before in a stylus. Most stylus have a protruding plastic top, and when you want to delete something on the screen, and you press down, the eraser actually presses down, and providing an audible clicking sound. This can be disjointing, because in the real world, erasers don't don't do this. This new eraser can be tilted, which makes deleting content fun!\r\n\r\nThe overall design is a bit different than normal plastic pens. This has a hexagonal shape, which makes it easy to hold and has a firm grip. One of the things that is very compelling about this new product is the sheer number of devices it supports. You can use it on the Remarkable 1 and Remarkable 2, Supernote, all of the Onyx e-notes made in the past three years and the previous generation of Boyue Likebook's. It retails for $89, making it more affordable than most premium stylus on the market. You can order it from the Good e-Reader Store.","author":{"@type":"Person","name":"Michael Kozlowski"},"datePublished":"2021-09-30"}],"aggregateRating":{"@type":"AggregateRating","bestRating":"5","worstRating":"0","ratingValue":"4.75","reviewCount":1}}</script> <div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" alt="" data-src="https://goodereader.com/blog/wp-content/litespeed/avatar/22c9d299e674ed5db5061197761719b5.jpg" data-srcset="https://goodereader.com/blog/wp-content/litespeed/avatar/658b30637f3783e4e03332f67e3bc482.jpg 2x" class="avatar avatar-100 photo" height="100" width="100" itemprop="image" loading="lazy"></div><div class="saboxplugin-authorname"><a href="https://goodereader.com/blog/author/michael-kozlowski" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Michael Kozlowski</span></a><span class="sabox-job-title" itemprop="jobTitle"><span class="sabox-job-title-par">(</span> Editor in Chief <span class="sabox-job-title-par">)</span></span></div><div class="saboxplugin-desc"><div itemprop="description"><p>Michael Kozlowski has been writing about audiobooks and e-readers for the past twelve years. His articles have been picked up by major and local news sources and websites such as the CBC, CNET, Engadget, Huffington Post and the New York Times. He Lives in Vancouver, British Columbia, Canada.</p></div></div><div class="clearfix"></div><div class="saboxplugin-socials "><a target="_blank" href="http://www.linkedin.com/in/michael-kozlowski-6777b71b" rel="nofollow" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-linkedin" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M100.3 480H7.4V180.9h92.9V480zM53.8 140.1C24.1 140.1 0 115.5 0 85.8 0 56.1 24.1 32 53.8 32c29.7 0 53.8 24.1 53.8 53.8 0 29.7-24.1 54.3-53.8 54.3zM448 480h-92.7V334.4c0-34.7-.7-79.2-48.3-79.2-48.3 0-55.7 37.7-55.7 76.7V480h-92.8V180.9h89.1v40.8h1.3c12.4-23.5 42.7-48.3 87.9-48.3 94 0 111.3 61.9 111.3 142.3V480z"></path></svg></a><a target="_blank" href="https://twitter.com/goodereadermike" rel="nofollow" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a target="_self" href="mailto:michael@goodereader.com" rel="nofollow" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-user_email" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 512 512"><path fill="currentColor" d="M502.3 190.8c3.9-3.1 9.7-.2 9.7 4.7V400c0 26.5-21.5 48-48 48H48c-26.5 0-48-21.5-48-48V195.6c0-5 5.7-7.8 9.7-4.7 22.4 17.4 52.1 39.5 154.1 113.6 21.1 15.4 56.7 47.8 92.2 47.6 35.7.3 72-32.8 92.3-47.6 102-74.1 131.6-96.3 154-113.7zM256 320c23.2.4 56.6-29.2 73.4-41.4 132.7-96.3 142.8-104.7 173.4-128.7 5.8-4.5 9.2-11.5 9.2-18.9v-19c0-26.5-21.5-48-48-48H48C21.5 64 0 85.5 0 112v19c0 7.4 3.4 14.3 9.2 18.9 30.6 23.9 40.7 32.4 173.4 128.7 16.8 12.2 50.2 41.8 73.4 41.4z"></path></svg></a></div></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="none" data-float-mobile="none" data-transition="slide" data-post-id="244322" ><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=iReader+X-Pen+with+Eraser+-+Hands+on+Review&url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review&via=goodereadermike" data-link="https://twitter.com/intent/tweet?text=iReader+X-Pen+with+Eraser+-+Hands+on+Review&url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review&via=goodereadermike"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_hacker_news" data-network="hacker_news"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://news.ycombinator.com/submitlink?u=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review&t=iReader%20X-Pen%20with%20Eraser%20-%20Hands%20on%20Review" data-link="https://news.ycombinator.com/submitlink?u=https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review&t=iReader%20X-Pen%20with%20Eraser%20-%20Hands%20on%20Review"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_hacker_news_icon"></i><span class="swp_share">Vote</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_email" data-network="email"><a class="nc_tweet noPop swp_share_link" rel="nofollow noreferrer noopener" href="mailto:?subject=iReader%20X-Pen%20with%20Eraser%20-%20Hands%20on%20Review&body=iReader%20has%20had%20multiple%20generations%20of%20stylus%20that%20are%20compatible%20with%20virtually%20any%20digital%20note%20taking%20device%20with%20a%20WACOM%20screen%20and%20the%20company%20has%20just%20released%20their%203rd%20generation%20model.%20One%20of%20the%20big%20changes%20from%20the%20previous%20generation%20is%20that%20the%20stylus%20now%20has%20an%20eraser%2C%20but%20it%20is%20quite%20different%20from%20most%20erasers%20on%20the%20market%2C%20since%20it%20is%20recessed%20and%20does%20not%20pop%20down%2C%20like%20many%20cheap%20erasers.%20It%20also%20has%20lost%20the%20clip%2C%20which%20now%20makes%20it%20easier%20to%20hold.%20The%20iReader%20X-Pen%20with%20eraser%20comes%20in%20white%20and%20is%20quite%20easy%20to%20hold%20in%0D%0A%0D%0ARead More Here: %20https%3A%2F%2Fgoodereader.com%2Fblog%2Freviews%2Fireader-x-pen-with-eraser-hands-on-review" target="_blank"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_email_icon"></i><span class="swp_share">Email</span></span></span></span></a></div></div><div class="swp-content-locator"></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://goodereader.com/blog/category/reviews" rel="category tag">e-Reader Reviews</a></span></p></footer></article><div id="disqus_thread"></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="adrotate_widgets-28" class="widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-41"><center><script type="litespeed/javascript" data-i="2" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5776314496161013"
data-ad-slot="2642032174"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript" data-i="3">(adsbygoogle=window.adsbygoogle||[]).push({})</script></center></div></div></section><section id="adrotate_widgets-22" class="widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-26"><center><div id="amzn-assoc-ad-bf4ce168-2a3c-4a8f-9ebb-ba7117979d68"></div></center></div></div></section><section id="adrotate_widgets-23" class="widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-41"><center><script type="litespeed/javascript" data-i="2" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5776314496161013"
data-ad-slot="2642032174"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript" data-i="3">(adsbygoogle=window.adsbygoogle||[]).push({})</script></center></div></div></section><section id="wtpsw-post-list-widget-2" class="widget wtpsw_post_list_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Trending</h3><div class="wtpsw-post-items"><ul><li class="wtpsw-post-li"><div class="wtpsw-post-thumb-left">
<a href="https://goodereader.com/blog/electronic-readers/amazon-is-going-to-release-kindle-paperwhite-5-signature-edition-soon">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" width="100" height="100" data-src="https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-100x100.png" class="attachment-100x100 size-100x100 wp-post-image" alt="" loading="lazy" data-srcset="https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-100x100.png 100w, https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-540x540.png 540w, https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-180x180.png 180w, https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-62x62.png 62w, https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-32x32.png 32w, https://goodereader.com/blog/uploads/images/2021/09/Screenshot-2021-09-19-at-21-39-27-Kindle-now-with-a-built-in-front-light-Black-Amazon-ca-Amazon-Devices-Accessories-170x170.png 170w" data-sizes="(max-width: 100px) 100vw, 100px" />        </a></div><div class="wtpsw-post-thumb-right"><h6> <a class="wtpsw-post-title" href="https://goodereader.com/blog/electronic-readers/amazon-is-going-to-release-kindle-paperwhite-5-signature-edition-soon">Amazon is going to release Kindle Paperwhite 5 Signature Edition Soon</a></h6><div class="wtpsw-date-post">September 20, 2021</div><div class="wtpsw-post-stats">
<span class='wtpsw-post-author'>By <a href='https://goodereader.com/blog/author/michael-kozlowski'>Michael Kozlowski</a></span> | <span class='wtpsw-post-comment'>368 Comments</span></div></div></li><li class="wtpsw-post-li"><div class="wtpsw-post-thumb-left">
<a href="https://goodereader.com/blog/electronic-readers/will-the-kindle-paperwhite-5-have-a-6-8-inch-screen">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" width="100" height="100" data-src="https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-100x100.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" loading="lazy" data-srcset="https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-100x100.jpg 100w, https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-540x540.jpg 540w, https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-180x180.jpg 180w, https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-62x62.jpg 62w, https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-32x32.jpg 32w, https://goodereader.com/blog/uploads/images/2021/09/amazon-kindle-10-170x170.jpg 170w" data-sizes="(max-width: 100px) 100vw, 100px" />        </a></div><div class="wtpsw-post-thumb-right"><h6> <a class="wtpsw-post-title" href="https://goodereader.com/blog/electronic-readers/will-the-kindle-paperwhite-5-have-a-6-8-inch-screen">Will the Kindle Paperwhite 5 have a 6.8 inch screen?</a></h6><div class="wtpsw-date-post">September 9, 2021</div><div class="wtpsw-post-stats">
<span class='wtpsw-post-author'>By <a href='https://goodereader.com/blog/author/michael-kozlowski'>Michael Kozlowski</a></span> | <span class='wtpsw-post-comment'>28 Comments</span></div></div></li><li class="wtpsw-post-li"><div class="wtpsw-post-thumb-left">
<a href="https://goodereader.com/blog/electronic-readers/onyx-boox-mira-and-mira-pro-now-available-for-pre-order">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" width="100" height="100" data-src="https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-100x100.webp" class="attachment-100x100 size-100x100 wp-post-image" alt="" loading="lazy" data-srcset="https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-100x100.webp 100w, https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-540x540.webp 540w, https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-180x180.webp 180w, https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-62x62.webp 62w, https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-32x32.webp 32w, https://goodereader.com/blog/uploads/images/2021/09/Mira-web_13-170x170.webp 170w" data-sizes="(max-width: 100px) 100vw, 100px" />        </a></div><div class="wtpsw-post-thumb-right"><h6> <a class="wtpsw-post-title" href="https://goodereader.com/blog/electronic-readers/onyx-boox-mira-and-mira-pro-now-available-for-pre-order">Onyx Boox Mira and Mira Pro Now Available for Pre-Order</a></h6><div class="wtpsw-date-post">September 9, 2021</div><div class="wtpsw-post-stats">
<span class='wtpsw-post-author'>By <a href='https://goodereader.com/blog/author/michael-kozlowski'>Michael Kozlowski</a></span> | <span class='wtpsw-post-comment'>16 Comments</span></div></div></li><li class="wtpsw-post-li"><div class="wtpsw-post-thumb-left">
<a href="https://goodereader.com/blog/electronic-readers/why-e-reading-continues-to-reign-supreme">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" width="100" height="100" data-src="https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-100x100.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" loading="lazy" data-srcset="https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-100x100.jpg 100w, https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-540x540.jpg 540w, https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-180x180.jpg 180w, https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-62x62.jpg 62w, https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-32x32.jpg 32w, https://goodereader.com/blog/uploads/images/2021/08/E9pRvE-XoAUJCoJ-170x170.jpg 170w" data-sizes="(max-width: 100px) 100vw, 100px" />        </a></div><div class="wtpsw-post-thumb-right"><h6> <a class="wtpsw-post-title" href="https://goodereader.com/blog/electronic-readers/why-e-reading-continues-to-reign-supreme">Why E-Reading Continues to Reign Supreme</a></h6><div class="wtpsw-date-post">August 30, 2021</div><div class="wtpsw-post-stats">
<span class='wtpsw-post-author'>By <a href='https://goodereader.com/blog/author/markus'>Markus Reily</a></span> | <span class='wtpsw-post-comment'>5 Comments</span></div></div></li><li class="wtpsw-post-li"><div class="wtpsw-post-thumb-left">
<a href="https://goodereader.com/blog/electronic-readers/topjoy-butterfly-now-available-on-kickstarter">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" width="100" height="100" data-src="https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-100x100.png" class="attachment-100x100 size-100x100 wp-post-image" alt="" loading="lazy" data-srcset="https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-100x100.png 100w, https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-540x540.png 540w, https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-180x180.png 180w, https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-62x62.png 62w, https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-32x32.png 32w, https://goodereader.com/blog/uploads/images/2021/09/TopJoy-Butterfly-Pocket-Sized-True-Color-DES-Screen-E-Reader-170x170.png 170w" data-sizes="(max-width: 100px) 100vw, 100px" />        </a></div><div class="wtpsw-post-thumb-right"><h6> <a class="wtpsw-post-title" href="https://goodereader.com/blog/electronic-readers/topjoy-butterfly-now-available-on-kickstarter">Topjoy Butterfly now available on Kickstarter</a></h6><div class="wtpsw-date-post">September 1, 2021</div><div class="wtpsw-post-stats">
<span class='wtpsw-post-author'>By <a href='https://goodereader.com/blog/author/michael-kozlowski'>Michael Kozlowski</a></span> | <span class='wtpsw-post-comment'>9 Comments</span></div></div></li><li class="wtpsw-post-li"><div class="wtpsw-post-thumb-left">
<a href="https://goodereader.com/blog/electronic-readers/upcoming-ereaders-and-enotes-people-are-most-excited-about">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCIgaGVpZ2h0PSIxMDAiIHZpZXdCb3g9IjAgMCAxMDAgMTAwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" width="100" height="100" data-src="https://goodereader.com/blog/uploads/images/2021/09/inkpad_lite-100x100.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" loading="lazy" data-srcset="https://goodereader.com/blog/uploads/images/2021/09/inkpad_lite-100x100.jpg 100w, https://goodereader.com/blog/uploads/images/2021/09/inkpad_lite-180x180.jpg 180w, https://goodereader.com/blog/uploads/images/2021/09/inkpad_lite-62x62.jpg 62w, https://goodereader.com/blog/uploads/images/2021/09/inkpad_lite-32x32.jpg 32w, https://goodereader.com/blog/uploads/images/2021/09/inkpad_lite-170x170.jpg 170w" data-sizes="(max-width: 100px) 100vw, 100px" />        </a></div><div class="wtpsw-post-thumb-right"><h6> <a class="wtpsw-post-title" href="https://goodereader.com/blog/electronic-readers/upcoming-ereaders-and-enotes-people-are-most-excited-about">Upcoming eReaders and eNotes people are most excited about</a></h6><div class="wtpsw-date-post">September 8, 2021</div><div class="wtpsw-post-stats">
<span class='wtpsw-post-author'>By <a href='https://goodereader.com/blog/author/sovy'>Sovan Mandal</a></span> | <span class='wtpsw-post-comment'>6 Comments</span></div></div></li></ul></div></div></section><section id="text-2" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="amzn-assoc-ad-bf4ce168-2a3c-4a8f-9ebb-ba7117979d68"></div><p></p></div></div></section><section id="adrotate_widgets-32" class="widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-41"><center><script type="litespeed/javascript" data-i="2" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5776314496161013"
data-ad-slot="2642032174"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript" data-i="3">(adsbygoogle=window.adsbygoogle||[]).push({})</script></center></div></div></section><section id="social-widget-4" class="widget Social_Widget"><div class="widget-wrap"><div class="socialmedia-buttons smw_left"><a href="https://youtube.com/goodereader/" rel="nofollow" target="_blank"><img width="32" height="32" src="https://goodereader.com/blog/images/svg/youtube-video-you-tube-movie-icon.svg"
alt=" YouTube"
title=" YouTube" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://twitter.com/goodereader/" rel="nofollow" target="_blank"><img width="32" height="32" src="https://goodereader.com/blog/images/svg/Twitter_Social_Icon_Rounded_Square_Color.svg"
alt=" Twitter"
title=" Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://facebook.com/goodereader/" rel="nofollow" target="_blank"><img width="32" height="32" src="https://goodereader.com/blog/images/svg/image2vector.svg"
alt=" Facebook"
title=" Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a></div></div></section></aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap">Copyright &#x000A9;&nbsp;2021  Good e-Reader Inc. - <A HREF="https://goodereader.com/blog/privacy-policy">Privacy Policy</A> -
<A HREF="https://goodereader.com/blog/terms-of-use">Terms of Use </A> -
<A HREF="https://goodereader.com/blog/store-usage-policy">Shipping and Return Policy</A> - <A HREF="https://goodereader.com/blog/customer-support">Customer Service</A></div></footer></div><div id="yith-wacp-popup" class="fade-in"><div class="yith-wacp-overlay"></div><div class="yith-wacp-wrapper woocommerce"><div class="yith-wacp-main"><div class="yith-wacp-head">
<a href="#"
class="yith-wacp-close">X Close</a></div><div class="yith-wacp-content"></div></div></div></div><div id="yith-wacp-mini-cart" class="empty"><div class="yith-wacp-mini-cart-count">0</div><div class="yith-wacp-mini-cart-icon">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjM1cCIgaGVpZ2h0PSIiIHZpZXdCb3g9IjAgMCAzNXAgIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBzdHlsZT0iZmlsbDojY2ZkNGRiO2ZpbGwtb3BhY2l0eTogMC4xOyIvPjwvc3Zn" data-src="https://goodereader.com/blog/wp-content/plugins/yith-woocommerce-added-to-cart-popup-premium/assets/images/mini-cart.png" width="35px" height="35px"></div></div>
<noscript>
<img
height="1"
width="1"
style="display:none"
alt="fbpx"
src="https://www.facebook.com/tr?id=2289720401245280&ev=PageView&noscript=1"
/>
</noscript>
<style type="text/css">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</style> <script src='https://goodereader.com/blog/wp-content/plugins/LayerSlider/assets/static/layerslider/js/layerslider.kreaturamedia.jquery.js?ver=6.11.9' id='layerslider-js'></script>  <script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"$1");litespeed_vary||fetch("https://goodereader.com/blog/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&window.location.reload(!0)});</script><script data-optimized="1" type="litespeed/javascript" data-i="10" data-src="https://goodereader.com/blog/wp-content/litespeed/js/8e0c45588128ada88b6f5f8c2f4d2bcb.js?ver=0c95c"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var litespeed_delay_i=0,urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_forced(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(function(e){window.removeEventListener(e,litespeed_load_delayed_js_forced,{passive:!0})}),litespeed_load_delayed_js(!0),document.querySelectorAll("iframe[data-litespeed-src]").forEach(function(e){e.setAttribute("src",e.getAttribute("data-litespeed-src"))})}function litespeed_load_delayed_js(e){e&&console.log("[LiteSpeed] Force running delayed JS"),litespeed_load_one()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}function litespeed_load_one(){litespeed_delay_i++;var t,d=document.querySelector('script[type="litespeed/javascript"][data-i="'+litespeed_delay_i+'"]');d?(console.log("[LiteSpeed] Load i="+d.getAttribute("data-i"),"-----",d),(t=document.createElement("script")).addEventListener("load",function(){console.log("[LiteSpeed] loaded --- "+t.getAttribute("data-i")),litespeed_load_one()},{passive:!0}),t.addEventListener("error",function(){console.log("[LiteSpeed] loaded error! --- "+t.getAttribute("data-i")),litespeed_load_one()},{passive:!0}),d.getAttributeNames().forEach(function(e){"type"!=e&&t.setAttribute("data-src"==e?"src":e,d.getAttribute(e))}),t.type="text/javascript",!t.src&&d.textContent&&(t.src=litespeed_inline2src(d.textContent)),d.after(t),d.remove()):console.log("[LiteSpeed] All loaded!")}litespeed_ui_events.forEach(function(e){window.addEventListener(e,litespeed_load_delayed_js_forced,{passive:!0})});</script></body><style>ul.products li {
    overflow: hidden !important; 
}</style></html>
<!-- Page optimized by LiteSpeed Cache @2021-09-30 23:37:16 -->
<!-- Page generated by LiteSpeed Cache 4.4.3-a6 on 2021-09-30 19:37:15 -->
<!-- Guest Mode -->